firmware-utils/mkfwimage: add RouterStation support (based on a patch by Jonas <jonas...
[openwrt/openwrt.git] / target / linux / atheros / image / Makefile
index 5cfa774041b0886f3d9a49ee7aac4995f5a3d0f6..4340e769df90b241b27e37e7979934f62154fe8a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
-       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
        $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
-       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.lzma bs=65536 conv=sync
-       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.gz bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
+       dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync
 endef
 
 define Image/Build/squashfs
@@ -21,8 +21,30 @@ endef
 
 define Image/Build
        $(call Image/Build/$(1))
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-root.$(1) bs=128k conv=sync
-endef
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS2 -v XS2.ar2316.OpenWrt \
+               -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt2-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage \
+               -B XS5 -v XS5.ar2313.OpenWrt \
+               -k $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma \
+               -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-ubnt5-$(1).bin
 
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B np25g \
+               -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz  \
+               -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               $(BIN_DIR)/openwrt-$(BOARD)-np25g-$(1).bin
+
+       -$(STAGING_DIR_HOST)/bin/mkmylofw -B wpe53g \
+               -p0x020000:0x130000:ah:0x80041000:linux:$(KDIR)/vmlinux.bin.gz  \
+               -p0x150000:0x2a0000:::rootfs:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+               $(BIN_DIR)/openwrt-$(BOARD)-wpe53g-$(1).bin
+
+endef
 
 $(eval $(call BuildImage))