bcm53xx: early buttons support (without interrupts)
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index e8e8b431b6a8ed5ff2cbfcee429fdc1af3a6f813..519b5a553065e9068da14519cfc87f09dcf6bafc 100644 (file)
@@ -8,12 +8,13 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
+CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.14.14
+LINUX_VERSION:=3.14.18
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -23,6 +24,8 @@ endef
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))