ar71xx: ubnt-rocket-m-ti: fix RSSI LED definitions
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 69f30f84ec99e220147dbebc10eb4cd51f5505db..6c19263fdfbe64a9142fd8c97c76a943fc61df29 100644 (file)
@@ -12,19 +12,21 @@ BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
 FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.14.18
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.14
+KERNEL_TESTING_PATCHVER := 4.19
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
        kmod-gpio-button-hotplug \
        kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer