bcm53xx: rename patches that were not upstreamed to 3xx
[openwrt/openwrt.git] / target / linux / bcm53xx / patches-3.14 / 304-ARM-BCM5301X-Add-DT-for-Asus-RT-N18U.patch
index 68db912f86b1ae9f27f1a26d36bf7d42612e1d14..2dfe3b1a4a0c66ded8127baea69cebf5e58f154a 100644 (file)
@@ -1,4 +1,4 @@
-From 3f3217b834f59c584f1a213c039349b4a3bb44d3 Mon Sep 17 00:00:00 2001
+From 89fe6f9b7875f74e7d63a90ae3a51d84d3cf9369 Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <zajec5@gmail.com>
 Date: Thu, 9 Oct 2014 18:16:26 +0200
 Subject: [PATCH] ARM: BCM5301X: Add DT for Asus RT-N18U
@@ -8,19 +8,17 @@ Content-Transfer-Encoding: 8bit
 
 Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
 ---
- arch/arm/boot/dts/Makefile                  |  3 ++-
- arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 35 +++++++++++++++++++++++++++++
- arch/arm/boot/dts/bcm47081.dtsi             | 26 +++++++++++++++++++++
+ arch/arm/boot/dts/Makefile                  |  3 +-
+ arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts | 88 +++++++++++++++++++++++++++++
+ arch/arm/boot/dts/bcm47081.dtsi             | 26 +++++++++
  arch/arm/mach-bcm/bcm_5301x.c               |  1 +
- 4 files changed, 64 insertions(+), 1 deletion(-)
+ 4 files changed, 117 insertions(+), 1 deletion(-)
  create mode 100644 arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
  create mode 100644 arch/arm/boot/dts/bcm47081.dtsi
 
-diff --git a/arch/arm/boot/dts/Makefile b/arch/arm/boot/dts/Makefile
-index 17c717b..330e0e0 100644
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -53,7 +53,8 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rpi-b.dtb
+@@ -53,7 +53,8 @@ dtb-$(CONFIG_ARCH_BCM2835) += bcm2835-rp
  dtb-$(CONFIG_ARCH_BCM_5301X) += \
        bcm4708-buffalo-wzr-1750dhp.dtb \
        bcm4708-netgear-r6250.dtb \
@@ -30,12 +28,9 @@ index 17c717b..330e0e0 100644
  dtb-$(CONFIG_ARCH_BERLIN) += \
        berlin2-sony-nsz-gs7.dtb        \
        berlin2cd-google-chromecast.dtb
-diff --git a/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
-new file mode 100644
-index 0000000..e6347a9
 --- /dev/null
 +++ b/arch/arm/boot/dts/bcm47081-asus-rt-n18u.dts
-@@ -0,0 +1,35 @@
+@@ -0,0 +1,88 @@
 +/*
 + * Broadcom BCM470X / BCM5301X arm platform code.
 + * DTS for Asus RT-N18U
@@ -54,7 +49,7 @@ index 0000000..e6347a9
 +      model = "Asus RT-N18U (BCM47081)";
 +
 +      chosen {
-+              bootargs = "console=ttyS0,115200";
++              bootargs = "console=ttyS0,115200 earlyprintk";
 +      };
 +
 +      memory {
@@ -70,10 +65,60 @@ index 0000000..e6347a9
 +                      status = "okay";
 +              };
 +      };
++
++      leds {
++              compatible = "gpio-leds";
++
++              power {
++                      label = "bcm53xx:blue:power";
++                      gpios = <&chipcommon 0 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              usb2 {
++                      label = "bcm53xx:blue:usb2";
++                      gpios = <&chipcommon 3 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++
++              wan {
++                      label = "bcm53xx:blue:wan";
++                      gpios = <&chipcommon 6 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              lan {
++                      label = "bcm53xx:blue:lan";
++                      gpios = <&chipcommon 9 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-on";
++              };
++
++              usb3 {
++                      label = "bcm53xx:blue:usb3";
++                      gpios = <&chipcommon 14 GPIO_ACTIVE_LOW>;
++                      linux,default-trigger = "default-off";
++              };
++      };
++
++      gpio-keys {
++              compatible = "gpio-keys-polled";
++              #address-cells = <1>;
++              #size-cells = <0>;
++              poll-interval = <200>;
++
++              restart {
++                      label = "Reset";
++                      linux,code = <KEY_RESTART>;
++                      gpios = <&chipcommon 7 GPIO_ACTIVE_LOW>;
++              };
++
++              wps {
++                      label = "WPS";
++                      linux,code = <KEY_WPS_BUTTON>;
++                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
++              };
++      };
 +};
-diff --git a/arch/arm/boot/dts/bcm47081.dtsi b/arch/arm/boot/dts/bcm47081.dtsi
-new file mode 100644
-index 0000000..f720012
 --- /dev/null
 +++ b/arch/arm/boot/dts/bcm47081.dtsi
 @@ -0,0 +1,26 @@
@@ -103,11 +148,9 @@ index 0000000..f720012
 +              };
 +      };
 +};
-diff --git a/arch/arm/mach-bcm/bcm_5301x.c b/arch/arm/mach-bcm/bcm_5301x.c
-index b0a6da9..de29646 100644
 --- a/arch/arm/mach-bcm/bcm_5301x.c
 +++ b/arch/arm/mach-bcm/bcm_5301x.c
-@@ -81,6 +81,7 @@ static void bcm5301x_restart(enum reboot_mode mode, const char *cmd)
+@@ -81,6 +81,7 @@ static void bcm5301x_restart(enum reboot
  
  static const char __initconst *bcm5301x_dt_compat[] = {
        "brcm,bcm4708",
@@ -115,6 +158,3 @@ index b0a6da9..de29646 100644
        NULL,
  };
  
--- 
-1.8.4.5
-