brcm47xx: use b53 phy driver for the switch in kernel 3.10
[openwrt/staging/mkresin.git] / target / linux / brcm47xx / Makefile
index 3ec9bbb83f64c0b82f2d7d4945a04d682c22bfe6..8d412adf530c26fb0ce1c9b8291d3a9905a85138 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += swconfig kmod-switch kmod-diag wpad-mini nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers