ramips: add support for MTC Wireless Router WR1201
[openwrt/openwrt.git] / target / linux / brcm47xx / Makefile
index 36205aed617a8f0b7e4fbd0fe2e5e42a1080c56e..af91d8bada52a58264b1cb2d5b34555c35c2f1db 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,21 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mipsel
 BOARD:=brcm47xx
-BOARDNAME:=Broadcom BCM947xx/953xx
+BOARDNAME:=Broadcom BCM47xx/53xx (MIPS)
 FEATURES:=squashfs usb
+SUBTARGETS:=generic mips74k legacy
+MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=2.6.25.16
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
-       Build firmware images for Broadcom based routers
-       (e.g. Netgear WGT634U)
+       Build firmware images for Broadcom based BCM47xx/53xx routers with MIPS CPU, *not* ARM.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += swconfig nvram otrx \
+       kmod-leds-gpio kmod-gpio-button-hotplug \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev
+
 $(eval $(call BuildTarget))