brcm63xx: CPVA502+ board fixes
[openwrt/staging/mkresin.git] / target / linux / brcm63xx / Makefile
index dec4806d47c7c4eea4314d948e1a85cfe569263b..02596a138f719a1a8adace851d67fe3c23192a7a 100644 (file)
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.30.10
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+LINUX_VERSION:=3.10.44
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers