Fix nxp_74hc164 driver compile error (builbot)
[openwrt/openwrt.git] / target / linux / brcm63xx / Makefile
index 9e35957a2b9a44e4f5c92e813a32a9478d19aff9..9873db3382ff715df0fd61c08d6daceef441b0ae 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.27
+FEATURES:=squashfs jffs2 usb atm pci pcmcia
+LINUX_VERSION:=2.6.35.7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += wpad-mini kmod-switch gpioctl
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
-       currently supports BCM6348 and BCM6358 based devices.
-       (e.g. Inventel Livebox, Siemens SE515)
+       currently supports BCM6338, BCM6348 and BCM6358 based devices.
+       (e.g. Inventel Livebox, Siemens SE515, Neufbox 4)
 endef
 
 $(eval $(call BuildTarget))