lantiq: add missing default lan interface
[openwrt/openwrt.git] / target / linux / cns3xxx / Makefile
index c1f127accfd5518b8f621ad6544be5cd764a52ed..c8d62519ce6b097e92ef73c6dcc16832bb87b2b1 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=cns3xxx
 BOARDNAME:=Cavium Networks Econa CNS3xxx
-FEATURES:=squashfs fpu gpio broken
-CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=squashfs fpu gpio pcie usb usbgadget
+CPU_TYPE:=mpcore
+CPU_SUBTYPE:=vfp
+MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
-LINUX_VERSION:=3.3.7
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build images for Cavium Networks Econa CNS3xxx based boards,
        eg. the Gateworks Laguna family
 endef
 
-KERNELNAME:="uImage"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage
+
+DEFAULT_PACKAGES += kmod-ath9k kmod-usb2 wpad-mini
 
 $(eval $(call BuildTarget))