ar7: drop 3.14 support
[openwrt/openwrt.git] / target / linux / gemini / Makefile
index 29f3bb1c6aae6f5379afad8e7e39b4e139fda2f0..09f4c4352ab0342d38b7db2fd042cb7f501ca1b3 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2011 OpenWrt.org
+# Copyright (C) 2009-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs broken
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+SUBTARGETS:=raidsonic wiligear
+FEATURES:=squashfs pci rtc
+CPU_TYPE:=fa526
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.3
+KERNEL_PATCHVER:=3.10
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk