gemini: switch to 4.14
[openwrt/staging/mkresin.git] / target / linux / gemini / Makefile
index 0f0ecd3872f546b0a2e15fd0a5c4b15cec6dc1d4..a9414a26068716ee930ec9df07a7a2bac16db7cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2010 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
+FEATURES:=squashfs pci rtc usb dt gpio
+CPU_TYPE:=fa526
+MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
-LINUX_VERSION:=2.6.32.24
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk