gemini: switch to 4.14
[openwrt/staging/mkresin.git] / target / linux / gemini / Makefile
index f26f7bfde19172276b4c6e2d504bf62f4f755cd0..a9414a26068716ee930ec9df07a7a2bac16db7cc 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009-2013 OpenWrt.org
+# Copyright (C) 2009-2018 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,11 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=gemini
 BOARDNAME:=Cortina Systems CS351x
-FEATURES:=squashfs pci
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=squashfs pci rtc usb dt gpio
+CPU_TYPE:=fa526
+MAINTAINER:=Roman Yeryomin <roman@advem.lv>
 
-LINUX_VERSION:=3.9.3
+KERNEL_PATCHVER:=4.14
+
+define Target/Description
+       Build firmware images for the StorLink/Cortina Gemini CS351x ARM FA526 CPU
+endef
+
+KERNELNAME:=zImage dtbs
 
 include $(INCLUDE_DIR)/target.mk