gemini: fix parallel build
[openwrt/openwrt.git] / target / linux / gemini / image / Makefile
index 908045a2de3c5ed674754d8335d50e8147141efa..5f987875d318e71db593c33b5fa8db60f41a9ac5 100644 (file)
@@ -7,9 +7,20 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-# Build the special D-Link DNS-313 header generator tool
-# needed to generate the hard disk boot images then
-# build D-Link DNS-313 images using the special header tool.
+# Cook a "WRGG" image, this board is apparently one in the D-Link
+# WRGG family and uses the exact same firmware format as other
+# D-Link devices.
+define Build/dir685-images
+       mkwrggimg -i $(IMAGE_KERNEL) \
+       -o $(BIN_DIR)/$(IMG_PREFIX)-dir685-fwupdate.bin \
+       -d /dev/mtdblock/1 \
+       -s wrgns01_dlwbr_dir685RBWW \
+       -v 'N/A' \
+       -m dir685 \
+       -B 96bb
+endef
+
+# Build D-Link DNS-313 images using the special header tool.
 # rootfs.tgz and rd.tgz contains nothing, we only need them
 # to satisfy the boot loader on the device. The zImage is
 # the only real content.
@@ -28,19 +39,23 @@ define Build/dns313-images
        if [ -d $(BIN_DIR)/.boot ] ; then rm -rf $(BIN_DIR)/.boot ; fi
 endef
 
-# Create the special NAS4220B image format with the squashfs
-# split across two "partitions" named rd.gz and hddapp.tgz but
-# essentially just being used by OpenWRT as one big partition
-define Build/nas4220b-images
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/rd.gz bs=6144k conv=sync
-       dd if=$(IMAGE_ROOTFS) of=$(BIN_DIR)/hddapp.tgz bs=6144k count=1 seek=1
-       cp $(IMAGE_KERNEL) $(BIN_DIR)/zImage
-       cp ./ImageInfo-ib4220 $(BIN_DIR)/ImageInfo
-       (cd $(BIN_DIR); tar -czf $(IMG_PREFIX)-sysupgrade-ib4220b.tar.gz ImageInfo zImage rd.gz hddapp.tgz)
-       mv $(BIN_DIR)/rd.gz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-rd.gz
-       mv $(BIN_DIR)/hddapp.tgz $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-hddapp.tgz
-       mv $(BIN_DIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-nas4220b-zImage
-       rm -f $(BIN_DIR)/ImageInfo
+# Create the special NAS4220B and Itian Square One SQ201 image
+# format with the squashfs and overlay inside the "rd.gz" file.
+# We pad it out to 6144K which is the size of the initramfs partition.
+#
+# The "application" partition is just blank. You can put anything
+# there when using OpenWRT. We just use that to create the
+# "sysupgrade" firmware image.
+define Build/nas4220b-sq201-images
+       rm -rf $@-tmp
+       mkdir -p $@-tmp
+       dd if=$(IMAGE_ROOTFS) of=$@-tmp/rd.gz bs=6144k conv=sync
+       dd if=/dev/zero of=$@-tmp/hddapp.tgz bs=6144k count=1
+       cp $(IMAGE_KERNEL) $@-tmp/zImage
+       cp ./ImageInfo-$(1) $@-tmp/ImageInfo
+       (cd $@-tmp; tar --owner=0 --group=0 --numeric-owner --mtime=@$(SOURCE_DATE_EPOCH) \
+                       -czf $@ ImageInfo zImage rd.gz hddapp.tgz)
+       rm -rf $@-tmp
 endef
 
 # WBD-111 and WBD-222:
@@ -56,12 +71,13 @@ endef
 
 # All DTB files are prefixed with "gemini-"
 define Device/Default
+       PROFILES := Default
        DEVICE_DTS := $(patsubst %.dtb,%,$(notdir $(wildcard $(if $(IB),$(KDIR),$(DTS_DIR))/*-$(1).dtb)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_NAME := zImage
        KERNEL := kernel-bin | append-dtb
        FILESYSTEMS := squashfs
-       IMAGE_NAME := $$(IMAGE_PREFIX)-$$(1).$$(2)
+       IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
        BLOCKSIZE := 128k
        PAGESIZE := 2048
 endef
@@ -70,34 +86,41 @@ endef
 # of devices out of the box (former NAS42x0 IcyBox defaults)
 GEMINI_NAS_PACKAGES:=kmod-md-mod kmod-md-linear kmod-md-multipath \
                kmod-md-raid0 kmod-md-raid1 kmod-md-raid10 kmod-md-raid456 \
-               kmod-fs-btrfs kmod-fs-cifs kmod-fs-ext4 kmod-fs-nfs \
+               kmod-fs-btrfs kmod-fs-cifs kmod-fs-nfs \
                kmod-fs-nfsd kmod-fs-ntfs kmod-fs-reiserfs kmod-fs-vfat \
                kmod-nls-utf8 kmod-usb-storage-extras \
                samba36-server mdadm cfdisk fdisk e2fsprogs badblocks
 
-DIR685_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda1 rw rootwait
 define Device/dlink-dir-685
        DEVICE_TITLE := D-Link DIR-685 Xtreme N Storage Router
-       CMDLINE := $(DIR685_CMDLINE)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) \
+                       kmod-switch-rtl8366rb swconfig \
+                       rt2800-pci
+       IMAGES += dir685-image
+       IMAGE/dir685-image := dir685-images
 endef
 TARGET_DEVICES += dlink-dir-685
 
-DNS313_CMDLINE:=-console=ttyS0,19200n8 root=/dev/sda4 rw rootwait
 define Device/dlink-dns-313
        DEVICE_TITLE := D-Link DNS-313 1-Bay Network Storage Enclosure
-       CMDLINE := $(DNS313_CMDLINE)
        DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
        IMAGES += dns313-image
        IMAGE/dns313-image := dns313-images
 endef
 TARGET_DEVICES += dlink-dns-313
 
+define Device/nas4220b-sq201
+       ARTIFACTS := zImage
+       ARTIFACT/zImage := append-kernel
+       IMAGES += rd.gz sysupgrade.tar.gz
+       IMAGE/rd.gz := append-rootfs | pad-to 6144k
+       IMAGE/sysupgrade.tar.gz := nas4220b-sq201-images $(1)
+       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
+endef
+
 define Device/nas4220b
+       $(Device/nas4220b-sq201)
        DEVICE_TITLE := Raidsonic NAS IB-4220-B
-       IMAGES += nas4220b-image
-       IMAGE/nas4220b-image := nas4220b-images
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES)
 endef
 TARGET_DEVICES += nas4220b
 
@@ -107,11 +130,10 @@ define Device/rut1xx
 endef
 TARGET_DEVICES += rut1xx
 
-SQ201_CMDLINE:=-console=ttyS0,115200n8
 define Device/sq201
+       $(Device/nas4220b-sq201)
        DEVICE_TITLE := ITian Square One SQ201
-       CMDLINE := $(SQ201_CMDLINE)
-       DEVICE_PACKAGES := $(GEMINI_NAS_PACKAGES) rt61-pci-firmware
+       DEVICE_PACKAGES += rt61-pci usb2-pci
 endef
 TARGET_DEVICES += sq201