kernel: bump 5.15 to 5.15.89
[openwrt/openwrt.git] / target / linux / generic / hack-5.15 / 259-regmap_dynamic.patch
index bc81a7285c007ad18c5a3a02b467d4f5dd30eac2..6be5875177cfd3d20966ace69a0751dc91d44ac1 100644 (file)
@@ -14,18 +14,19 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/base/regmap/Kconfig
 +++ b/drivers/base/regmap/Kconfig
-@@ -4,9 +4,8 @@
+@@ -4,10 +4,9 @@
  # subsystems should select the appropriate symbols.
  
  config REGMAP
--      default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_W1 || REGMAP_AC97 || REGMAP_MMIO || REGMAP_IRQ || REGMAP_SOUNDWIRE || REGMAP_SCCB || REGMAP_I3C || REGMAP_SPI_AVMM)
+-      default y if (REGMAP_I2C || REGMAP_SPI || REGMAP_SPMI || REGMAP_W1 || REGMAP_AC97 || REGMAP_MMIO || REGMAP_IRQ || REGMAP_SOUNDWIRE || REGMAP_SOUNDWIRE_MBQ || REGMAP_SCCB || REGMAP_I3C || REGMAP_SPI_AVMM || REGMAP_MDIO)
        select IRQ_DOMAIN if REGMAP_IRQ
+       select MDIO_BUS if REGMAP_MDIO
 -      bool
 +      tristate
  
  config REGCACHE_COMPRESSED
        select LZO_COMPRESS
-@@ -14,46 +13,59 @@ config REGCACHE_COMPRESSED
+@@ -15,53 +14,67 @@ config REGCACHE_COMPRESSED
        bool
  
  config REGMAP_AC97
@@ -33,57 +34,65 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        tristate
  
  config REGMAP_I2C
-       tristate
 +      select REGMAP
+       tristate
        depends on I2C
  
  config REGMAP_SLIMBUS
-       tristate
 +      select REGMAP
+       tristate
        depends on SLIMBUS
  
  config REGMAP_SPI
-       tristate
 +      select REGMAP
-+      depends on SPI_MASTER
+       tristate
        depends on SPI
  
  config REGMAP_SPMI
-       tristate
 +      select REGMAP
+       tristate
        depends on SPMI
  
  config REGMAP_W1
-       tristate
 +      select REGMAP
+       tristate
        depends on W1
  
- config REGMAP_MMIO
+ config REGMAP_MDIO
++      select REGMAP
        tristate
+ config REGMAP_MMIO
 +      select REGMAP
+       tristate
  
  config REGMAP_IRQ
-       bool
 +      select REGMAP
+       bool
  
  config REGMAP_SOUNDWIRE
++      select REGMAP
        tristate
+       depends on SOUNDWIRE
+ config REGMAP_SOUNDWIRE_MBQ
 +      select REGMAP
+       tristate
        depends on SOUNDWIRE
  
  config REGMAP_SCCB
-       tristate
 +      select REGMAP
+       tristate
        depends on I2C
  
  config REGMAP_I3C
-       tristate
 +      select REGMAP
+       tristate
        depends on I3C
  
  config REGMAP_SPI_AVMM
-       tristate
 +      select REGMAP
+       tristate
        depends on SPI
 --- a/drivers/base/regmap/Makefile
 +++ b/drivers/base/regmap/Makefile
@@ -116,7 +125,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <linux/mutex.h>
  #include <linux/err.h>
  #include <linux/property.h>
-@@ -3298,3 +3299,5 @@ static int __init regmap_initcall(void)
+@@ -3341,3 +3342,5 @@ static int __init regmap_initcall(void)
        return 0;
  }
  postcore_initcall(regmap_initcall);
@@ -124,7 +133,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +MODULE_LICENSE("GPL");
 --- a/include/linux/regmap.h
 +++ b/include/linux/regmap.h
-@@ -179,7 +179,7 @@ struct reg_sequence {
+@@ -180,7 +180,7 @@ struct reg_sequence {
        __ret ?: __tmp; \
  })