kernel: modules: add xdp-sockets-diag support
[openwrt/openwrt.git] / target / linux / generic / hack-5.15 / 321-powerpc_crtsavres_prereq.patch
index 4bb438295de234893b2392ec19649f7a5130c1f7..f1942e2037598df3b6c5d1407d8fb27d57229bbb 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 
 --- a/arch/powerpc/Makefile
 +++ b/arch/powerpc/Makefile
-@@ -61,19 +61,6 @@ machine-$(CONFIG_PPC64) += 64
+@@ -44,19 +44,6 @@ machine-$(CONFIG_PPC64) += 64
  machine-$(CONFIG_CPU_LITTLE_ENDIAN) += le
  UTS_MACHINE := $(subst $(space),,$(machine-y))
  
@@ -24,7 +24,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
 -ifdef CONFIG_PPC32
 -KBUILD_LDFLAGS_MODULE += arch/powerpc/lib/crtsavres.o
 -else
--ifeq ($(call ld-ifversion, -ge, 225000000, y),y)
+-ifeq ($(call ld-ifversion, -ge, 22500, y),y)
 -# Have the linker provide sfpr if possible.
 -# There is a corresponding test in arch/powerpc/lib/Makefile
 -KBUILD_LDFLAGS_MODULE += --save-restore-funcs