kernel: bump 5.15 to 5.15.107
[openwrt/openwrt.git] / target / linux / generic / hack-5.15 / 430-mtk-bmt-support.patch
index 62ddd66bf2efd50dd86b67876e8b4a5b82354194..2a83f46e0ee8af837b130334259ee332df58351b 100644 (file)
@@ -1,8 +1,18 @@
+From ac84397efb3b3868c71c10ad7521161773228a17 Mon Sep 17 00:00:00 2001
+From: OpenWrt community <openwrt-devel@lists.openwrt.org>
+Date: Wed, 13 Jul 2022 13:41:44 +0200
+Subject: [PATCH] mtd/nand: add MediaTek NAND bad block managment table
+
+---
+ drivers/mtd/nand/Kconfig  | 4 ++++
+ drivers/mtd/nand/Makefile | 1 +
+ 2 files changed, 5 insertions(+)
+
 --- a/drivers/mtd/nand/Kconfig
 +++ b/drivers/mtd/nand/Kconfig
-@@ -15,6 +15,10 @@ config MTD_NAND_ECC
-        bool
-        depends on MTD_NAND_CORE
+@@ -46,6 +46,10 @@ config MTD_NAND_ECC_SW_BCH
+         ECC codes. They are used with NAND devices requiring more than 1 bit
+         of error correction.
  
 +config MTD_NAND_MTK_BMT
 +      bool "Support MediaTek NAND Bad-block Management Table"