kernel: mtd: backport SafeLoader parser
[openwrt/openwrt.git] / target / linux / generic / pending-5.10 / 435-mtd-add-routerbootpart-parser-config.patch
index 446bc0bef103b284a07582e8e34fc2fe792b4fa6..5c7b57b373d05bcbd6d8fab69c007e150daa79d0 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 
 --- a/drivers/mtd/parsers/Kconfig
 +++ b/drivers/mtd/parsers/Kconfig
-@@ -204,3 +204,12 @@ config MTD_SERCOMM_PARTS
+@@ -219,3 +219,12 @@ config MTD_SERCOMM_PARTS
          partition map. This partition table contains real partition
          offsets, which may differ from device to device depending on the
          number and location of bad blocks on NAND.
@@ -31,7 +31,7 @@ Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
 +       formatted DTS.
 --- a/drivers/mtd/parsers/Makefile
 +++ b/drivers/mtd/parsers/Makefile
-@@ -14,3 +14,4 @@ obj-$(CONFIG_MTD_PARSER_TRX)         += parser_
+@@ -15,3 +15,4 @@ obj-$(CONFIG_MTD_PARSER_TRX)         += parser_
  obj-$(CONFIG_MTD_SERCOMM_PARTS)               += scpart.o
  obj-$(CONFIG_MTD_SHARPSL_PARTS)               += sharpslpart.o
  obj-$(CONFIG_MTD_REDBOOT_PARTS)               += redboot.o