remove ipset support from core, it is now provided by xtables-addons from the package...
[openwrt/openwrt.git] / target / linux / generic-2.4 / patches / 051-remove_pcmcia_modinst_compat.patch
index 091e4ba7a4b368d376aad50f4fb872e509ea48e7..1b5773677606ab5fa28aec7428fa850eedcbc321 100644 (file)
@@ -1,13 +1,13 @@
---- linux.old/Makefile Tue Oct 10 22:24:41 2006
-+++ linux.dev/Makefile Tue Oct 10 22:26:19 2006
-@@ -427,17 +427,8 @@
+--- a/Makefile
++++ b/Makefile
+@@ -431,18 +431,9 @@ else
  depmod_opts   := -b $(INSTALL_MOD_PATH) -r
  endif
  .PHONY: _modinst_post
 -_modinst_post: _modinst_post_pcmcia
 +_modinst_post:
        if [ -r System.map ]; then $(DEPMOD) -ae -F System.map $(depmod_opts) $(KERNELRELEASE); fi
--
 -# Backwards compatibilty symlinks for people still using old versions
 -# of pcmcia-cs with hard coded pathnames on insmod.  Remove
 -# _modinst_post_pcmcia for kernel 2.4.1.
@@ -16,6 +16,7 @@
 -      cd $(MODLIB); \
 -      mkdir -p pcmcia; \
 -      find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
+-
  .PHONY: $(patsubst %, _modinst_%, $(SUBDIRS))
  $(patsubst %, _modinst_%, $(SUBDIRS)) :
+       $(MAKE) -C $(patsubst _modinst_%, %, $@) modules_install