refresh generic 2.6.25 patches
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.25 / 001-squashfs.patch
index 77128cc5bbbe2c9e9bffe1f1ca7f36ac6be7ad4d..bb84e3c1a28d5832c85c93cad641dd5d3337f7f1 100644 (file)
@@ -1,7 +1,7 @@
-Index: linux-2.6.25.1/fs/Kconfig
+Index: linux-2.6.25.4/fs/Kconfig
 ===================================================================
---- linux-2.6.25.1.orig/fs/Kconfig
-+++ linux-2.6.25.1/fs/Kconfig
+--- linux-2.6.25.4.orig/fs/Kconfig
++++ linux-2.6.25.4/fs/Kconfig
 @@ -1367,6 +1367,71 @@ config CRAMFS
  
          If unsure, say N.
@@ -74,10 +74,10 @@ Index: linux-2.6.25.1/fs/Kconfig
  config VXFS_FS
        tristate "FreeVxFS file system support (VERITAS VxFS(TM) compatible)"
        depends on BLOCK
-Index: linux-2.6.25.1/fs/Makefile
+Index: linux-2.6.25.4/fs/Makefile
 ===================================================================
---- linux-2.6.25.1.orig/fs/Makefile
-+++ linux-2.6.25.1/fs/Makefile
+--- linux-2.6.25.4.orig/fs/Makefile
++++ linux-2.6.25.4/fs/Makefile
 @@ -73,6 +73,7 @@ obj-$(CONFIG_JBD)            += jbd/
  obj-$(CONFIG_JBD2)            += jbd2/
  obj-$(CONFIG_EXT2_FS)         += ext2/
@@ -86,10 +86,10 @@ Index: linux-2.6.25.1/fs/Makefile
  obj-y                         += ramfs/
  obj-$(CONFIG_HUGETLBFS)               += hugetlbfs/
  obj-$(CONFIG_CODA_FS)         += coda/
-Index: linux-2.6.25.1/fs/squashfs/inode.c
+Index: linux-2.6.25.4/fs/squashfs/inode.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/fs/squashfs/inode.c
++++ linux-2.6.25.4/fs/squashfs/inode.c
 @@ -0,0 +1,2122 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2213,10 +2213,10 @@ Index: linux-2.6.25.1/fs/squashfs/inode.c
 +MODULE_DESCRIPTION("squashfs, a compressed read-only filesystem");
 +MODULE_AUTHOR("Phillip Lougher <phillip@lougher.org.uk>");
 +MODULE_LICENSE("GPL");
-Index: linux-2.6.25.1/fs/squashfs/Makefile
+Index: linux-2.6.25.4/fs/squashfs/Makefile
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/fs/squashfs/Makefile
++++ linux-2.6.25.4/fs/squashfs/Makefile
 @@ -0,0 +1,7 @@
 +#
 +# Makefile for the linux squashfs routines.
@@ -2225,10 +2225,10 @@ Index: linux-2.6.25.1/fs/squashfs/Makefile
 +obj-$(CONFIG_SQUASHFS) += squashfs.o
 +squashfs-y += inode.o
 +squashfs-y += squashfs2_0.o
-Index: linux-2.6.25.1/fs/squashfs/squashfs2_0.c
+Index: linux-2.6.25.4/fs/squashfs/squashfs2_0.c
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/fs/squashfs/squashfs2_0.c
++++ linux-2.6.25.4/fs/squashfs/squashfs2_0.c
 @@ -0,0 +1,758 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -2988,10 +2988,10 @@ Index: linux-2.6.25.1/fs/squashfs/squashfs2_0.c
 +
 +      return 1;
 +}
-Index: linux-2.6.25.1/fs/squashfs/squashfs.h
+Index: linux-2.6.25.4/fs/squashfs/squashfs.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/fs/squashfs/squashfs.h
++++ linux-2.6.25.4/fs/squashfs/squashfs.h
 @@ -0,0 +1,86 @@
 +/*
 + * Squashfs - a compressed read only filesystem for Linux
@@ -3079,10 +3079,10 @@ Index: linux-2.6.25.1/fs/squashfs/squashfs.h
 +      return 0;
 +}
 +#endif
-Index: linux-2.6.25.1/include/linux/magic.h
+Index: linux-2.6.25.4/include/linux/magic.h
 ===================================================================
---- linux-2.6.25.1.orig/include/linux/magic.h
-+++ linux-2.6.25.1/include/linux/magic.h
+--- linux-2.6.25.4.orig/include/linux/magic.h
++++ linux-2.6.25.4/include/linux/magic.h
 @@ -35,6 +35,9 @@
  #define REISER2FS_SUPER_MAGIC_STRING  "ReIsEr2Fs"
  #define REISER2FS_JR_SUPER_MAGIC_STRING       "ReIsEr3Fs"
@@ -3093,10 +3093,10 @@ Index: linux-2.6.25.1/include/linux/magic.h
  #define SMB_SUPER_MAGIC               0x517B
  #define USBDEVICE_SUPER_MAGIC 0x9fa2
  #define CGROUP_SUPER_MAGIC    0x27e0eb
-Index: linux-2.6.25.1/include/linux/squashfs_fs.h
+Index: linux-2.6.25.4/include/linux/squashfs_fs.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/squashfs_fs.h
++++ linux-2.6.25.4/include/linux/squashfs_fs.h
 @@ -0,0 +1,911 @@
 +#ifndef SQUASHFS_FS
 +#define SQUASHFS_FS
@@ -4009,10 +4009,10 @@ Index: linux-2.6.25.1/include/linux/squashfs_fs.h
 +
 +#endif
 +#endif
-Index: linux-2.6.25.1/include/linux/squashfs_fs_i.h
+Index: linux-2.6.25.4/include/linux/squashfs_fs_i.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/squashfs_fs_i.h
++++ linux-2.6.25.4/include/linux/squashfs_fs_i.h
 @@ -0,0 +1,45 @@
 +#ifndef SQUASHFS_FS_I
 +#define SQUASHFS_FS_I
@@ -4059,10 +4059,10 @@ Index: linux-2.6.25.1/include/linux/squashfs_fs_i.h
 +      struct inode    vfs_inode;
 +};
 +#endif
-Index: linux-2.6.25.1/include/linux/squashfs_fs_sb.h
+Index: linux-2.6.25.4/include/linux/squashfs_fs_sb.h
 ===================================================================
 --- /dev/null
-+++ linux-2.6.25.1/include/linux/squashfs_fs_sb.h
++++ linux-2.6.25.4/include/linux/squashfs_fs_sb.h
 @@ -0,0 +1,74 @@
 +#ifndef SQUASHFS_FS_SB
 +#define SQUASHFS_FS_SB
@@ -4138,10 +4138,10 @@ Index: linux-2.6.25.1/include/linux/squashfs_fs_sb.h
 +      int                     (*read_fragment_index_table)(struct super_block *s);
 +};
 +#endif
-Index: linux-2.6.25.1/init/do_mounts_rd.c
+Index: linux-2.6.25.4/init/do_mounts_rd.c
 ===================================================================
---- linux-2.6.25.1.orig/init/do_mounts_rd.c
-+++ linux-2.6.25.1/init/do_mounts_rd.c
+--- linux-2.6.25.4.orig/init/do_mounts_rd.c
++++ linux-2.6.25.4/init/do_mounts_rd.c
 @@ -5,6 +5,7 @@
  #include <linux/ext2_fs.h>
  #include <linux/romfs_fs.h>