when using -O2 instead of -Os, get rid of the two optimizations that are causing...
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.28 / 004-extra_optimization.patch
index d6866899c302126c29c359ad749c1d5fea7c5ef7..8827ed0c3d6134121507006ea7c6c42c6a2c67d1 100644 (file)
@@ -1,5 +1,14 @@
 --- a/Makefile
 +++ b/Makefile
+@@ -512,7 +512,7 @@ all: vmlinux
+ ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
+ KBUILD_CFLAGS += -Os
+ else
+-KBUILD_CFLAGS += -O2
++KBUILD_CFLAGS += -O2 -fno-reorder-blocks -fno-tree-ch
+ endif
+ include $(srctree)/arch/$(SRCARCH)/Makefile
 @@ -549,6 +549,9 @@ endif
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)