update OCF framework to version 20100325
[openwrt/openwrt.git] / target / linux / generic-2.6 / patches-2.6.30 / 970-ocf_kbuild_integration.patch
index bf229eab8256a6ecb696ab285892048cb6dbea29..02fd8855bb01336df257223b09dc67e23c746150 100644 (file)
@@ -1,25 +1,20 @@
 --- a/crypto/Kconfig
 +++ b/crypto/Kconfig
-@@ -784,6 +784,8 @@ config CRYPTO_ANSI_CPRNG
-         for cryptographic modules.  Uses the Algorithm specified in
-         ANSI X9.31 A.2.4
-+source "crypto/ocf/Kconfig"
-+
+@@ -781,3 +781,6 @@ config CRYPTO_ANSI_CPRNG
  source "drivers/crypto/Kconfig"
  
  endif # if CRYPTO
++
++source "crypto/ocf/Kconfig"
++
 --- a/crypto/Makefile
 +++ b/crypto/Makefile
-@@ -86,6 +86,11 @@ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_
+@@ -84,6 +84,8 @@ obj-$(CONFIG_CRYPTO_RNG2) += krng.o
+ obj-$(CONFIG_CRYPTO_ANSI_CPRNG) += ansi_cprng.o
  obj-$(CONFIG_CRYPTO_TEST) += tcrypt.o
  
- #
-+# OCF
-+#
 +obj-$(CONFIG_OCF_OCF) += ocf/
 +
-+#
+ #
  # generic algorithms and the async_tx api
  #
- obj-$(CONFIG_XOR_BLOCKS) += xor.o