* adds patch to 2.6.35 series to make dsl work
[openwrt/openwrt.git] / target / linux / ifxmips / Makefile
index 4767dce71eb23ac12c204e432393b3703b656d28..53558ef79bd85ea5cddd7370e5d56988de5677e9 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.7
+FEATURES:=squashfs jffs2 atm
+SUBTARGETS:=danube ar9
+
+LINUX_VERSION:=2.6.35.8
+
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=uboot-lantiq kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl ifxmips-dsl-api ifxmips-dsl-control tapi_sip lqtapi_firmware_danube
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers