some additional config file cleanup..
[openwrt/openwrt.git] / target / linux / ifxmips / Makefile
index 19f11eafdfd2ca33c0e76527caafe414a0ce3b13..eee0d44e919124d8d8f016091d5bec9de37c7200 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
-FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.1
+FEATURES:=squashfs jffs2
+
+LINUX_VERSION:=2.6.28.10
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
 endef
 
+ifeq ($(KERNEL_PATCHVER),2.6.28)
+  define Kernel/Prepare
+       $(call Kernel/Prepare/Default)
+       mv $(LINUX_DIR)/include/asm-mips/* $(LINUX_DIR)/arch/mips/include/asm/
+  endef
+endif
+
 $(eval $(call BuildTarget))