treewide: convert MAC address location offsets to hexadecimal
[openwrt/openwrt.git] / target / linux / ipq40xx / Makefile
index 390426c18dce1d9f636323673e67475844c04e0b..9b78d1f1bfc5c6145e584ee988cad6bf8296175b 100644 (file)
@@ -3,19 +3,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq40xx
 BOARDNAME:=Qualcomm Atheros IPQ40XX
-FEATURES:=squashfs fpu
+FEATURES:=squashfs fpu ramdisk nand
 CPU_TYPE:=cortex-a7
 CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.14
+KERNEL_PATCHVER:=4.19
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
+       kmod-usb-dwc3-qcom \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ath10k wpad-mini \
-       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k-ct wpad-basic \
+       kmod-usb3 kmod-usb-dwc3 ath10k-firmware-qca4019-ct
 
 $(eval $(call BuildTarget))