ipq40xx: fix up Linksys WHW01 board name, device definition
[openwrt/openwrt.git] / target / linux / ipq40xx / image / generic.mk
index e17db37d8205de0499bb50ec2b04edc09116ff84..a2807c6c9c530d2d9d7abe57ea5c3816d005de23 100644 (file)
@@ -720,25 +720,22 @@ define Device/linksys_mr8300
 endef
 TARGET_DEVICES += linksys_mr8300
 
-define Device/linksys_whw01-v1
+define Device/linksys_whw01
        $(call Device/FitzImage)
        DEVICE_VENDOR := Linksys
        DEVICE_MODEL := WHW01
-       DEVICE_VARIANT := v1
        KERNEL_SIZE := 6144k
-       IMAGE_SIZE := 28704512  # 28032k minus linksys signature (256-bytes).
+       IMAGE_SIZE := 75776K
        SOC := qcom-ipq4018
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
        IMAGES += factory.bin
-       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | \
-               append-ubi | linksys-image type=WHW01 | pad-to $$$$(PAGESIZE) | \
-               check-size
+       IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=WHW01
        DEVICE_PACKAGES := uboot-envtools kmod-leds-pca963x
 endef
 # Missing DSA Setup
-#TARGET_DEVICES += linksys_whw01-v1
+#TARGET_DEVICES += linksys_whw01
 
 define Device/luma_wrtq-329acn
        $(call Device/FitImage)