ipq40xx: 5.10: move AR40xx to MDIO drivers
[openwrt/openwrt.git] / target / linux / ipq40xx / patches-5.10 / 705-net-add-qualcomm-ar40xx-phy.patch
index 6b0272bd72f86186f2e2ded9b24201375c9f8636..cd0b10c6c8a3f0fc007aa2f8313718e5df62d810 100644 (file)
@@ -1,26 +1,27 @@
---- a/drivers/net/phy/Kconfig
-+++ b/drivers/net/phy/Kconfig
-@@ -388,6 +388,13 @@ config XILINX_GMII2RGMII
-         the Reduced Gigabit Media Independent Interface(RGMII) between
-         Ethernet physical media devices and the Gigabit Ethernet controller.
+--- a/drivers/net/mdio/Kconfig
++++ b/drivers/net/mdio/Kconfig
+@@ -27,6 +27,13 @@ config OF_MDIO
+       help
+         OpenFirmware MDIO bus (Ethernet PHY) accessors
  
 +config AR40XX_PHY
-+      tristate "Driver for Qualcomm Atheros IPQ40XX switches"
-+      depends on HAS_IOMEM && OF && OF_MDIO
-+      select SWCONFIG
-+      help
-+         This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
++   tristate "Driver for Qualcomm Atheros IPQ40XX switches"
++   depends on HAS_IOMEM && OF && OF_MDIO
++   select SWCONFIG
++   help
++      This is the driver for Qualcomm Atheros IPQ40XX ESS switches.
 +
- endif # PHYLIB
+ if MDIO_BUS
  
- config MICREL_KS8995MA
---- a/drivers/net/phy/Makefile
-+++ b/drivers/net/phy/Makefile
-@@ -50,6 +50,7 @@ ifdef CONFIG_HWMON
- aquantia-objs                 += aquantia_hwmon.o
- endif
- obj-$(CONFIG_AQUANTIA_PHY)    += aquantia.o
-+obj-$(CONFIG_AR40XX_PHY)      += ar40xx.o
- obj-$(CONFIG_AT803X_PHY)      += at803x.o
- obj-$(CONFIG_AX88796B_PHY)    += ax88796b.o
- obj-$(CONFIG_BCM54140_PHY)    += bcm54140.o
+ config MDIO_DEVRES
+--- a/drivers/net/mdio/Makefile
++++ b/drivers/net/mdio/Makefile
+@@ -21,6 +21,8 @@ obj-$(CONFIG_MDIO_SUN4I)             += mdio-sun4i.
+ obj-$(CONFIG_MDIO_THUNDER)            += mdio-thunder.o
+ obj-$(CONFIG_MDIO_XGENE)              += mdio-xgene.o
++obj-$(CONFIG_AR40XX_PHY)              += ar40xx.o
++
+ obj-$(CONFIG_MDIO_BUS_MUX)            += mdio-mux.o
+ obj-$(CONFIG_MDIO_BUS_MUX_BCM_IPROC)  += mdio-mux-bcm-iproc.o
+ obj-$(CONFIG_MDIO_BUS_MUX_GPIO)               += mdio-mux-gpio.o