brcm2708-gpu-fw: update to latest version
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 38f342feb642296955d981462362bef5a94e32e1..45f83ddcdfa4f1c70fa9ea3625ccf7d803b4f4a3 100644 (file)
@@ -5,14 +5,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
+FEATURES:=squashfs nand ubifs
 CPU_TYPE:=cortex-a7
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.16
+KERNEL_PATCHVER:=3.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
+
 
 $(eval $(call BuildTarget))