kernel: backport mtd patch for minor partitioning cleanup
[openwrt/openwrt.git] / target / linux / ipq806x / Makefile
index 689ba649731fe19c82b53686d3d92432386f4952..e65c24db512ec6beb8074abd76d0eba6acd7bb14 100644 (file)
@@ -5,19 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand ubifs fpu
-CPU_TYPE:=cortex-a9
+FEATURES:=squashfs nand fpu
+CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.9
 
 KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
-
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k wpad-mini \
+       uboot-envtools
 
 $(eval $(call BuildTarget))