kernel: drop empty kmod-ledtrig-* packages
[openwrt/openwrt.git] / target / linux / ipq806x / modules.mk
index 57121bebb09acc9bfa8def8167b867dbd874c95b..605504b0c33867bd0ad944212c3097d74aeafc20 100644 (file)
@@ -1,32 +1,16 @@
-define KernelPackage/usb-phy-qcom-dwc3
-  TITLE:=DWC3 USB QCOM PHY driver
+define KernelPackage/phy-qcom-ipq806x-usb
+  TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
   DEPENDS:=@TARGET_ipq806x
-  KCONFIG:= CONFIG_PHY_QCOM_DWC3
-  FILES:= $(LINUX_DIR)/drivers/phy/phy-qcom-dwc3.ko
-  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-dwc3,1)
+  KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
+  FILES:= \
+    $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
+  AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
   $(call AddDepends/usb)
 endef
 
-define KernelPackage/usb-phy-qcom-dwc3/description
+define KernelPackage/phy-qcom-ipq806x-usb/description
  This driver provides support for the integrated DesignWare
  USB3 IP Core within the QCOM SoCs.
 endef
 
-$(eval $(call KernelPackage,usb-phy-qcom-dwc3))
-
-
-define KernelPackage/usb-dwc3-qcom
-  TITLE:=DWC3 USB QCOM controller driver
-  DEPENDS:=@TARGET_ipq806x +kmod-usb-dwc3 +kmod-usb-phy-dwc3-qcom
-  KCONFIG:= CONFIG_USB_DWC3_QCOM
-  FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3-qcom.ko
-  AUTOLOAD:=$(call AutoLoad,53,dwc3-qcom,1)
-  $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-dwc3-qcom/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,usb-dwc3-qcom))
+$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))