kernel: update 4.4 kernel to 4.4.42
[openwrt/openwrt.git] / target / linux / ipq806x / patches-4.4 / 111-PCI-qcom-Add-Qualcomm-PCIe-controller-driver.patch
index ad1a1b9cb37d307e670eaaa5fe93f2af81c5cd17..b140787ac773c086a34bbf506d46e993e1c87c32 100644 (file)
@@ -34,7 +34,7 @@ MAINTAINERS                  |    7 +
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -8253,6 +8253,13 @@
+@@ -8248,6 +8248,13 @@ S:      Maintained
  F:    Documentation/devicetree/bindings/pci/hisilicon-pcie.txt
  F:    drivers/pci/host/pcie-hisi.c
  
@@ -50,7 +50,7 @@ MAINTAINERS                  |    7 +
  L:    linux-pcmcia@lists.infradead.org
 --- a/drivers/pci/host/Kconfig
 +++ b/drivers/pci/host/Kconfig
-@@ -173,4 +173,13 @@
+@@ -173,4 +173,13 @@ config PCI_HISI
        help
          Say Y here if you want PCIe controller support on HiSilicon HIP05 SoC
  
@@ -745,7 +745,7 @@ MAINTAINERS                  |    7 +
 +MODULE_ALIAS("platform:qcom-pcie");
 --- a/drivers/pci/host/Makefile
 +++ b/drivers/pci/host/Makefile
-@@ -20,3 +20,4 @@
+@@ -20,3 +20,4 @@ obj-$(CONFIG_PCIE_IPROC_BCMA) += pcie-ip
  obj-$(CONFIG_PCIE_ALTERA) += pcie-altera.o
  obj-$(CONFIG_PCIE_ALTERA_MSI) += pcie-altera-msi.o
  obj-$(CONFIG_PCI_HISI) += pcie-hisi.o