update to 2.6.25.1 and refresh patches
[openwrt/openwrt.git] / target / linux / ixp4xx / patches-2.6.25 / 030-ixp4xx_fsg_board_support.patch
index de874e44ad53a1ed7fd890c8e451c621ecf25c0b..5a2fb4ca03307a4c908f0bb6a54067ad68286ac7 100644 (file)
@@ -45,10 +45,10 @@ now calls machine_restart() directly.
  create mode 100644 arch/arm/mach-ixp4xx/fsg-setup.c
  create mode 100644 include/asm-arm/arch-ixp4xx/fsg.h
 
-diff --git a/arch/arm/configs/ixp4xx_defconfig b/arch/arm/configs/ixp4xx_defconfig
-index efa0485..fc14932 100644
---- a/arch/arm/configs/ixp4xx_defconfig
-+++ b/arch/arm/configs/ixp4xx_defconfig
+Index: linux-2.6.25.1/arch/arm/configs/ixp4xx_defconfig
+===================================================================
+--- linux-2.6.25.1.orig/arch/arm/configs/ixp4xx_defconfig
++++ linux-2.6.25.1/arch/arm/configs/ixp4xx_defconfig
 @@ -165,6 +165,7 @@ CONFIG_ARCH_PRPMC1100=y
  CONFIG_MACH_NAS100D=y
  CONFIG_MACH_DSMG600=y
@@ -94,10 +94,10 @@ index efa0485..fc14932 100644
  CONFIG_RTC_DRV_X1205=y
  CONFIG_RTC_DRV_PCF8563=y
  # CONFIG_RTC_DRV_PCF8583 is not set
-diff --git a/arch/arm/mach-ixp4xx/Kconfig b/arch/arm/mach-ixp4xx/Kconfig
-index e774447..db8b5fe 100644
---- a/arch/arm/mach-ixp4xx/Kconfig
-+++ b/arch/arm/mach-ixp4xx/Kconfig
+Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Kconfig
+===================================================================
+--- linux-2.6.25.1.orig/arch/arm/mach-ixp4xx/Kconfig
++++ linux-2.6.25.1/arch/arm/mach-ixp4xx/Kconfig
 @@ -125,6 +125,15 @@ config    ARCH_IXDP4XX
        depends on ARCH_IXDP425 || MACH_IXDP465 || MACH_KIXRP435
        default y
@@ -114,11 +114,11 @@ index e774447..db8b5fe 100644
  #
  # Certain registers and IRQs are only enabled if supporting IXP465 CPUs
  #
-diff --git a/arch/arm/mach-ixp4xx/Makefile b/arch/arm/mach-ixp4xx/Makefile
-index c195688..2e6bbf9 100644
---- a/arch/arm/mach-ixp4xx/Makefile
-+++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -15,6 +15,7 @@ obj-pci-$(CONFIG_MACH_NAS100D)               += nas100d-pci.o
+Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/Makefile
+===================================================================
+--- linux-2.6.25.1.orig/arch/arm/mach-ixp4xx/Makefile
++++ linux-2.6.25.1/arch/arm/mach-ixp4xx/Makefile
+@@ -15,6 +15,7 @@ obj-pci-$(CONFIG_MACH_NAS100D)               += nas10
  obj-pci-$(CONFIG_MACH_DSMG600)                += dsmg600-pci.o
  obj-pci-$(CONFIG_MACH_GATEWAY7001)    += gateway7001-pci.o
  obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
@@ -126,7 +126,7 @@ index c195688..2e6bbf9 100644
  
  obj-y += common.o
  
-@@ -28,6 +29,7 @@ obj-$(CONFIG_MACH_NAS100D)   += nas100d-setup.o
+@@ -28,6 +29,7 @@ obj-$(CONFIG_MACH_NAS100D)   += nas100d-se
  obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o
  obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
  obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
@@ -134,11 +134,10 @@ index c195688..2e6bbf9 100644
  
  obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
  obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
-diff --git a/arch/arm/mach-ixp4xx/fsg-pci.c b/arch/arm/mach-ixp4xx/fsg-pci.c
-new file mode 100644
-index 0000000..f19f3f6
+Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-pci.c
+===================================================================
 --- /dev/null
-+++ b/arch/arm/mach-ixp4xx/fsg-pci.c
++++ linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-pci.c
 @@ -0,0 +1,71 @@
 +/*
 + * arch/arch/mach-ixp4xx/fsg-pci.c
@@ -211,11 +210,10 @@ index 0000000..f19f3f6
 +}
 +
 +subsys_initcall(fsg_pci_init);
-diff --git a/arch/arm/mach-ixp4xx/fsg-setup.c b/arch/arm/mach-ixp4xx/fsg-setup.c
-new file mode 100644
-index 0000000..0db3a90
+Index: linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-setup.c
+===================================================================
 --- /dev/null
-+++ b/arch/arm/mach-ixp4xx/fsg-setup.c
++++ linux-2.6.25.1/arch/arm/mach-ixp4xx/fsg-setup.c
 @@ -0,0 +1,276 @@
 +/*
 + * arch/arm/mach-ixp4xx/fsg-setup.c
@@ -493,11 +491,10 @@ index 0000000..0db3a90
 +      .init_machine   = fsg_init,
 +MACHINE_END
 +
-diff --git a/include/asm-arm/arch-ixp4xx/fsg.h b/include/asm-arm/arch-ixp4xx/fsg.h
-new file mode 100644
-index 0000000..c0100cc
+Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/fsg.h
+===================================================================
 --- /dev/null
-+++ b/include/asm-arm/arch-ixp4xx/fsg.h
++++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/fsg.h
 @@ -0,0 +1,50 @@
 +/*
 + * include/asm-arm/arch-ixp4xx/fsg.h
@@ -549,10 +546,10 @@ index 0000000..c0100cc
 +#define FSG_LED_USB_BIT               4
 +#define FSG_LED_RING_BIT      5
 +#define FSG_LED_SYNC_BIT      7
-diff --git a/include/asm-arm/arch-ixp4xx/hardware.h b/include/asm-arm/arch-ixp4xx/hardware.h
-index 73e8dc3..fa723a6 100644
---- a/include/asm-arm/arch-ixp4xx/hardware.h
-+++ b/include/asm-arm/arch-ixp4xx/hardware.h
+Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/hardware.h
+===================================================================
+--- linux-2.6.25.1.orig/include/asm-arm/arch-ixp4xx/hardware.h
++++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/hardware.h
 @@ -45,5 +45,6 @@
  #include "nslu2.h"
  #include "nas100d.h"
@@ -560,10 +557,10 @@ index 73e8dc3..fa723a6 100644
 +#include "fsg.h"
  
  #endif  /* _ASM_ARCH_HARDWARE_H */
-diff --git a/include/asm-arm/arch-ixp4xx/irqs.h b/include/asm-arm/arch-ixp4xx/irqs.h
-index 1180160..674af4a 100644
---- a/include/asm-arm/arch-ixp4xx/irqs.h
-+++ b/include/asm-arm/arch-ixp4xx/irqs.h
+Index: linux-2.6.25.1/include/asm-arm/arch-ixp4xx/irqs.h
+===================================================================
+--- linux-2.6.25.1.orig/include/asm-arm/arch-ixp4xx/irqs.h
++++ linux-2.6.25.1/include/asm-arm/arch-ixp4xx/irqs.h
 @@ -128,4 +128,11 @@
  #define        IRQ_DSMG600_PCI_INTE    IRQ_IXP4XX_GPIO7
  #define        IRQ_DSMG600_PCI_INTF    IRQ_IXP4XX_GPIO6
@@ -576,6 +573,3 @@ index 1180160..674af4a 100644
 +#define        IRQ_FSG_PCI_INTC        IRQ_IXP4XX_GPIO5
 +
  #endif
--- 
-1.5.2.5
-