kirkwood: copy files to kernel 5.10
[openwrt/openwrt.git] / target / linux / kirkwood / Makefile
index 53471c637ce1ec17eeb70ca7aa6c2f1f06b2c3ec..94bee8ba2d94cef390254776d9117479b064ec3a 100644 (file)
@@ -1,24 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2009-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=usb nand squashfs
+FEATURES:=usb nand squashfs ramdisk
 CPU_TYPE:=xscale
-MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))