kirkwood: copy files to kernel 5.10
[openwrt/openwrt.git] / target / linux / kirkwood / Makefile
index f0dda5ae932aa330a77aabae5e62178355e99fe9..94bee8ba2d94cef390254776d9117479b064ec3a 100644 (file)
@@ -1,23 +1,21 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2009-2015 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=kirkwood
 BOARDNAME:=Marvell Kirkwood
-FEATURES:=targz usb jffs2_nand
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+FEATURES:=usb nand squashfs ramdisk
+CPU_TYPE:=xscale
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES +=
+DEFAULT_PACKAGES += uboot-envtools kmod-usb2
 
 $(eval $(call BuildTarget))