brcm63xx: Add DT support for HG553
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index fa74e95af8e3e1b0ca48b248c81cfa9bbaca6647..143c11066418298f1d0d7cb60118b2375b010465 100644 (file)
@@ -6,20 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
 
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=3.10.49
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))