brcm63xx: Add DT support for HG553
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index ffe8e1b9f2e4401ecf3a9545bfe189449d4f1bc9..143c11066418298f1d0d7cb60118b2375b010465 100644 (file)
@@ -7,13 +7,13 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
 
-LINUX_VERSION:=3.3.8
+LINUX_VERSION:=3.10.49
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC