kernel: update linux 3.8 to 3.8.6
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index a1b40600b083932ed41deb637d5f615f7b717f8a..210b85e5b449a1b52998a4f5e63e567492817de4 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.2.16
+LINUX_VERSION:=3.8.6
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC