archs38: only calculate entry point address when necessary
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 82e5c3926a51e0eb09d220f0d6e5f04dcf8f3937..3e4f48e7b12377c67c931ad3b2b81fe65541ee61 100644 (file)
@@ -6,15 +6,13 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39.2
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Lantiq SoC