archs38: only calculate entry point address when necessary
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index d5e7148af2e88ee1dfdddd83fcc537fa39bb669c..3e4f48e7b12377c67c931ad3b2b81fe65541ee61 100644 (file)
@@ -7,13 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.7.9
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Lantiq SoC