ramips: add helper variable for boardname
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index b9c228359fbe36da626a48929e7347e802943702..4ae3a9ab01c0790f6a90bc5fbcf1c6be0d4c8e0a 100644 (file)
@@ -6,15 +6,13 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=xway
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39.2
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware images for Lantiq SoC