brcm63xx: switch to board based failsafe networking
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index d5e7148af2e88ee1dfdddd83fcc537fa39bb669c..af4295cbb836e5c64a0dd8c853a8f1163e986d96 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS=xway ase falcon
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xrx200 xway xway_legacy
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.7.9
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC