bcm53xx: build images for Luxul ABR-4500 and XBR-4500 routers
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 8e0bef42542afb596968366784a83a8088447f33..ee3e42bcb0932f8fb41860a6775e45669d412e7d 100644 (file)
@@ -6,20 +6,18 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39.2
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))