treewide: backport support for nvmem on non platform devices
[openwrt/openwrt.git] / target / linux / lantiq / modules.mk
index e7fbad3a29590f924c8349c34125bb73ddbf96c5..14140b1095d3d80a19bb46e52805090be7bf49ec 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 I2C_LANTIQ_MODULES:= \
   CONFIG_I2C_LANTIQ:drivers/i2c/busses/i2c-lantiq
@@ -11,7 +8,7 @@ I2C_LANTIQ_MODULES:= \
 define KernelPackage/i2c-lantiq
   TITLE:=Lantiq I2C controller
   $(call i2c_defaults,$(I2C_LANTIQ_MODULES),52)
-  DEPENDS:=kmod-i2c-core @TARGET_lantiq_falcon
+  DEPENDS:=+kmod-i2c-core @TARGET_lantiq_falcon
 endef
 
 define KernelPackage/i2c-lantiq/description