kenrel: refresh patches
[openwrt/openwrt.git] / target / linux / lantiq / patches-3.18 / 0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
index 3854d3a6bddcc953f6e044512e695aabd817d1ec..04c2071f320ce76876a5128b69861050621f07ff 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +#endif /* _PCI_ATH_FIXUP */
 --- a/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
 +++ b/arch/mips/include/asm/mach-lantiq/xway/lantiq_soc.h
-@@ -90,5 +90,8 @@
+@@ -90,5 +90,8 @@ int xrx200_gphy_boot(struct device *dev,
  extern void ltq_pmu_enable(unsigned int module);
  extern void ltq_pmu_disable(unsigned int module);
  
@@ -41,7 +41,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  #endif /* _LTQ_XWAY_H__ */
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -2,4 +2,7 @@
+@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
  
  obj-y += vmmc.o tffs.o
  
@@ -590,7 +590,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 +device_initcall(of_ralink_eeprom_init);
 --- a/drivers/net/ethernet/lantiq_etop.c
 +++ b/drivers/net/ethernet/lantiq_etop.c
-@@ -161,7 +161,7 @@
+@@ -161,7 +161,7 @@ struct ltq_etop_priv {
        int tx_irq;
        int rx_irq;
  
@@ -599,7 +599,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        int mii_mode;
  
        spinlock_t lock;
-@@ -840,7 +840,11 @@
+@@ -840,7 +840,11 @@ ltq_etop_init(struct net_device *dev)
        if (err)
                goto err_hw;