mediatek: mt7622: add support for ELECOM WRC-X3200GST3
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index 67da8449aac230aa0bf925b9093dc9902515b4e3..5bdbb5bfcd03ae3acf80b79cfc65ab5299ba6407 100644 (file)
@@ -1,18 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2016 Jiang Yutang <jiangyutang1978@gmail.com>
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.9
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=armv8_64b armv8_32b
-MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.10
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4 rootfs-part boot-part
+SUBTARGETS:=armv8_64b armv7
 
 define Target/Description
        Build firmware images for NXP Layerscape based boards.
@@ -20,6 +17,7 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
+DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage \
+  mkf2fs e2fsprogs partx-utils
 
 $(eval $(call BuildTarget))