kernel: bump 4.14 to 4.14.91
[openwrt/openwrt.git] / target / linux / layerscape / Makefile
index 3def184b948bde18b7d5b6533797e9cc8b8d8d51..7bb12b85e1531b7a8169805b6a9d23d6aa78ad6f 100644 (file)
@@ -8,19 +8,17 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=layerscape
 BOARDNAME:=NXP Layerscape
-DEVICE_TYPE:=developerboard
-KERNEL_PATCHVER:=4.4
-KERNELNAME:=Image dtbs
-FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
+KERNEL_PATCHVER:=4.14
+FEATURES:=squashfs nand usb pcie gpio fpu ubifs ext4
+SUBTARGETS:=armv8_64b armv8_32b armv7
 MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
 
 $(eval $(call BuildTarget))