move patches to patches-2.6.36
[openwrt/openwrt.git] / target / linux / leon / Makefile
index eb3b83fcfe9c8b296f1e7c12f2a833020e47a20c..dca32aaf7e9f64cf5ee7d4a543a33bee76edddd2 100644 (file)
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=sparc
 BOARD:=leon
 BOARDNAME:=LEON
-FEATURES+=fpu tgz
+FEATURES+=fpu tgz broken
 
-CFLAGS:=-Os -pipe -mcpu=v8 -funit-at-a-time
+CFLAGS:=-Os -pipe -mcpu=v8 -fno-caller-saves
 KERNELNAME:="uImage"
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.36.4
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
+DEVICE_TYPE:=developerboard
+
 include $(INCLUDE_DIR)/target.mk
 
 $(eval $(call BuildTarget))