treewide: Remove self from MAINTAINER entries
[openwrt/openwrt.git] / target / linux / malta / Makefile
index 32e193ecce41bf573ffeda73e19e1896a9c71518..05969c8bffefa197aae74c4ce2d5e9f59ad8c166 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,15 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-SUBTARGETS:=le be
+CPU_TYPE:=24kc
+SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
+FEATURES:=cpiogz ext4 ramdisk squashfs targz
 
-LINUX_VERSION:=2.6.37.1
+KERNEL_PATCHVER:=4.19
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
+DEFAULT_PACKAGES += wpad-basic kmod-mac80211-hwsim kmod-pcnet32 mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))