mpc85xx: Patch HiveAP 330 u-boot to fix boot
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 8428bec6bc0d64e5d5631440a03a114bf9cf53bd..6bf096740e48b3041aa97143c642fe038415db8c 100644 (file)
@@ -1,34 +1,25 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=squashfs
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS:=generic p1020
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=4.9
+KERNEL_PATCHVER:=5.10
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
-
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2 \
+       uboot-envtools
 
 $(eval $(call BuildTarget))