mpc85xx: Patch HiveAP 330 u-boot to fix boot
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 94384a8866a12f7d2ab684f490262bb5558fc996..6bf096740e48b3041aa97143c642fe038415db8c 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
@@ -13,7 +11,7 @@ CPU_TYPE:=8540
 FEATURES:=squashfs ramdisk
 SUBTARGETS:=p1010 p1020 p2020
 
-KERNEL_PATCHVER:=5.4
+KERNEL_PATCHVER:=5.10
 
 KERNELNAME:=zImage
 
@@ -21,6 +19,7 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic-wolfssl kmod-usb2 \
+       uboot-envtools
 
 $(eval $(call BuildTarget))