layerscape: unbreak ehci-fsl interaction with mpc85xx
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 5f3ad6c3d4968774229e51cdaab06805347189e5..e08b00ab8e9baf31d440e82310b91d10824a5e80 100644 (file)
@@ -10,26 +10,18 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
-FEATURES:=squashfs
+FEATURES:=squashfs ramdisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020 p2020
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.14
 
-include $(INCLUDE_DIR)/target.mk
+KERNELNAME:=zImage
 
-KERNEL_IMAGES := zImage
-ifeq ($(SUBTARGET),generic)
-KERNEL_IMAGES += cuImage.tl-wdr4900-v1
-endif
+include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2
 
 $(eval $(call BuildTarget))